When audit logging is fully enabled on the server, copy and paste operations performed between the local client and the remote session do not generate any entries in the audit.log file. The clipboard functionality itself works correctly,...
In v10.2, the audit configuration was moved from node.cfg to server.cfg which provides the new "AuditLogs" key. However, the old and deprecated "EnableAuditlogs" key is still present in the node.cfg file and could...
Automatic configuration of the EGL capture library (libnxegl.so) may fail to integrate with the Wayland session startup on systems using LightDM. In particular with Wayfire 0.9 (lightweight Wayland 3D Compositor) connections to the...
The player on Windows may suddenly terminate when trying to forward a smartcard, during the loading of libpkcs11. Steps to reproduce: Connect from Windows to any server Navigate to 'Devices' > 'Smart card readers' in the...
After the upgrade of NoMachine Cloud Server from v. 9.8.2 to 10.0.59 with profile rules of class node in place, AD users may no longer be restricted to only their assigned nodes.
When setting the rule on a per-node basis to disable access to all nodes for all users: nxserver --ruleadd --system --class node --type all --value no using the --system parameter raises an error: NX> 538 ERROR: User: __system__ is not...
Problem has been reproduced on Fedora 43 and 44 and Redhat 10 with GNOME Shell 49.9 and 50.3. In case of Fedora an error message appears :"The session negotiaton failed. Error: Last operation failed" In case of Redhat the session...
When a node is added to a Cloud Server as an inverse node, by running the 'nxserver --serveradd' command on the node, and the administrator enables further authentication for that node, the setting is not taken into account when...
This problem has been reproduced on Ubuntu 24.04 Noble Numbat, KDE Plasma desktop environment with Wayland enabled. Moving the mouse to the bottom of the screen doesn't trigger the auto-hide function of the menu. In some cases,pressing...
When a user owns a NoMachine Network Personal subscription which allows for one connection, and has a running Network session, after that he/she switches the wi-fi or loses Internet connection for a moment, the session tries to reconnect...
