Knowledge Base
Searching in : Trouble report
ID:TR08X11943
Added on: 2026-08-17
Last Update: 2026-09-14
Solved in version: 10.1.7; 9.9.6
Platform: All Platforms
Product: NoMachine Server
Severity: Minor
Status: Solved
Print this article

Key-based authentication may fail under certain conditions

Key-based authentication can fail during session negotiation with the following error:
Undefined subroutine &NXNssUserManager::listgroups called

Workaround:
Add the following option to the server.cfg file on the NoMachine server the client is connecting to:
DisablePAMGroupRetrieval 1

 

SOLVED, Released in version 10.1.7; 9.9.6