Some parameters may not work when setting rules for nodes of an Enterprise Terminal Server
When setting the rule on a per-node basis to disable access to all nodes for all users:
nxserver --ruleadd --system --class node --type all --value no
using the --system parameter raises an error:
NX> 538 ERROR: User: __system__ is not a system user.
NX> 500 ERROR: Cannot add rule for user: NX system.
This parameter can be omitted in the command, since the rule is applied by default to all users.
The '--type all' parameter is instead ineffective and the rule is not applied to all nodes.
As a workaround, it's possible to disable access to each node, one by one. For example:
nxserver --ruleadd --class node --type node_name --value no
